Your server is running PHP version 4.4.9 but WordPress 3.7.3 requires at least 5.2.4.